Jak naprawić błąd w Wyszukaj.Pionowo

Problem związany z niedopasowanymi danymi

Bardzo często spotykamy się z sytuacją, gdzie błędy uniemożliwiają nam przeprowadzenie obliczeń w kolejnych komórkach Excela.

Ma to miejsce często w sytuacji, gdy stosujemy funkcję Wyszukaj.Pionowo. Funkcja ta tworzy relację między dwoma tabelami za pomocą wspólnej kolumny. Zaciąga wartości do komórek kojarząc dane między sobą.

W przykładzie poniżej widzimy, że do komórek w kolumnie C (Tabela 1) zaciągany jest obrót z roku 2017 z tabeli sąsiedniej (Tabela 2) po numerze NIP. Kolumna z NIP em jest kolumną, po której dane są kojarzone. Używana jest funkcja WYSZUKAJ.PIONOWO.



Zastosowana wyszukaj pionowo

To co robi w komórce C2 (pierwsza komórka z formułą), gdzie chcemy pobrać obrót z roku 2017 z Tabeli 2 można opisać w sposób następujący: =WYSZUKAJ.PIONOWO(A2;$E$1:$F$20;2;0) - Wyszukaj wartość, która znajduje się w komórce A2, w pierwszej kolumnie zakresu $E$1:$F$20, jeśli znajdziesz tę wartość (chodzi o numer NIP. 6960428266), to z tabeli $E$1:$F$20 pobierz dane z drugiej kolumny tabeli (czyli obrót 2017)

Niestety nie wszystkie numery NIP znajdziemy w Tabeli 2 i dlatego pojawia się informacja o niespójności danych w postaci błędu #ND.

Można temu zaradzić używając funkcji JEŻELI.BŁĄD w połączeniu z WYSZUKAJ.PIONOWO.

Jak ten błąd prosto naprawić?

Naprawianie problemu

  1. Mając już utworzoną wyszukaj.pionowo wycinamy ją z pierwszej komórki (C2) na pasku formuły.

    Wywołujemy kreatora funkcji

  2. Wywołujemy kreatora funkcji i wybieramy funkcję JEŻELI.BŁĄD

    Wywołujemy kreatora funkcji

  3. W pierwszym argumencie (Wartość) wklejamy całe wyszukaj.pionowo

     wklejamy wyszukaj.pionowo

  4. W drugim argumencie (wartość jeżeli błąd - czyli, CO MAM ROBIĆ JEŻELI WYSZUKAJ.PIONOWO ZWRÓCI BŁĄD) wprowadzamy wartość 0

    Wpisujemy 0 w wartość jeżeli fałsz

    Streszczając całą operację jednym zdaniem możemy powiedzieć. Jeżeli Wyszukaj.Pionowo zwróci błąd, to wpisz 0. Dla Liczb ) dla wartości tekstowych "".

Problem rozwiązany

Kopiujemy formułę w dół i wszystko działa prawidłowo

Wynik naszego działania

Problem związany z błędną formułą

Zakładając, że masz w planach użyć formuły: =WYSZUKAJ.PIONOWO(A2;$E$1:$F$20;2;0) możesz popełnić bardzo typowy błąd. Częstym problemem jest brak znaków dolara przy zakresie "Tabela Tablica" (Table Array), czyli formuła może wyglądać następująco: =WYSZUKAJ.PIONOWO(A2;E1:F20;2;0).

Problem pojawi się w momencie kopiowania formuły w dół. Brak adresów bezwzględnych doprowadzi do błędów w komórkach od komórki C2 w dół

Inne

POdstawowe informacje Baza wiedzy

Artykuły



Darmowe lekcje multimedialne

Wykłady są dostępne na urządzenia z ekranami o rozdzielczości powyżej 1000px

Nowości

Icons from Glyphicons Free, licensed under CC BY 3.0.